Movement - Brief outage for administrators on the platform – Incident details

Brief outage for administrators on the platform

Resolved
Major outage
Started 3 days agoLasted less than a minute
Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved

    We apologise for the brief outage today. This was due to a security change which took longer than expected to propagfate.